chessmail

Latest postings

Ich kann keine Züge mehr eingeben !??

Clever - 09.01.20    

ICh kann meine Spiele nicht weiter spielen, Spiele sind zwar aufrufbar, aber es lassen sich keine Züge mehr spielen/eingeben. Ist das ein allgemeines Problem gerade ??

siramon - 09.01.20    

Nein, kein allg. Problem - bei mir gehts...

Ohne genauere Angaben, schwierig dir zu helfen. Bist du mobil (Smartphone) oder mit einem Desktop-/Notebook-Computer hier am Start? Welcher Browser, welches Betriebssystem?

Am besten mal den Browsercache leeren und alle Browserupdates einspielen.

LG
Rolf

Clever - 09.01.20    

Ok, wenn es kein allgemeines Problem ist , habe ich schon mal einen Hinweis ;-) ICh bin fast ausschließlich mit meinem Tablet unterwegs und spiele von unterwegs. Muß ich dann mal zu Hause am PC in Ruhe nachscahuen, trotzdem erstmal vielen DAnk und schönen Tag .

Karl_Lang - 09.01.20    

Ist bei mir genauso. Auch das Analysebrett ist nicht im originalen sondern in einem neuen Fenster geöffnet.
Dort lässt sich aber auch nicht ziehen.
Karl

Karl_Lang - 09.01.20    

Auch iPad und Safari

algorithmus888 - 09.01.20    

Ich habe das gleiche Problem. Ich benutze ein ipad2.
Keine Zugeingaben mehr möglich :-((

shaack - 10.01.20    

Auf den bei uns getesteten iPads geht alles einwandfrei. Welche Versionen iOS und Safari sind denn installiert? Wurde versucht, den Browsercache zu leeren?

willysi - 10.01.20    

Hallo auf meinem iPad g3 unter Safari kann ich auch keine eigenen Züge mehr eingeben. Im Dezember klappte noch alles reibungslos.

Auf meinem Laptop unter win 10 klappt es reibungslos. Habe dort crome installiert.
Liebe Grüße, siggi

algorithmus888 - 10.01.20    

Ich habe auf dem IPad2 iOS Version 9.3.5
Vermutlich Safari Version 9 (hängt mit an der iOS-Version dran).
Browsercache wurde geleert, hat aber nichts gebracht.

Auf meinem ollen Desktop-PC läuft chessmail prima.

shaack - 10.01.20    

Das klingt alles so, als wenn das Problem auf älteren iPads auftritt, die kein aktuellen iOS mehr haben. Gibt es auch Probleme mit anderen Seiten? Hat jemand so ein Gerät in der Nähe von Celle? Ich kann das leider nicht testen. Sieht man irgendwelche Fehlermeldungen?

Karl_Lang - 10.01.20    

Älteres iPad stimmt. Ich habe ein iPad 3. Die Klickleiste unter dem Schachbrett ist grau, nicht schwarz, wie sonst immer. Lässt sich also nicht bedienen. Die Cacheleerung für diese iPads wird leider nirgends beschrieben.
Gruß und danke an shaak, Karl.

aguirre - 10.01.20    

Hallo, nutze iPhone 8 Software 12.3.1. , also nicht aktuell und kann ganz normal ziehen
Spiele mit dem Apfel aber übe die Desktopversion.

MarkD - 10.01.20    

... ich dachte neulich auch, ich könnte nicht ziehen, es lag aber daran, dass ich auf meinem neuen Android-Telefon immer wieder ausgeloggt werde und mich neu anmelden muss. Hat sich da etwas geändert?

shaack - 10.01.20    

Ich denke mal, dass es ein wirklich altes Gerät sein muss. Tritt der Fehler in iOS 9 in der Desktop- oder der Mobilversion auf?

siramon - 10.01.20    

uff, haben nicht, aber herausgefunden wie simulieren ;-) Disclaimer: ein Mac muss vorhanden sein *g*

Könnte es daran liegen? Verwendung von https://caniuse.com/#search=let ist in iOS 9.3.x nicht möglich (erst ab iOS 10).

Mein simuliertes iPad 2 (mit iOS 9.3.5) spukt u.a. an dieser Stelle Fehler: portal.js bei der Definition von Try in Zeile 300: let returnValue; (SyntaxError: Unexpected identifier 'returnValue')

Plus weitere Fehler:
[Error] ReferenceError: Can't find variable: cookieRead Global Code (bec5fba4a7fb44c6:60)
[Error] ReferenceError: Can't find variable: debugOut PollingScheduler (pollingscheduler.js:8) Global Code (pollingscheduler.js:1)
[Error] ReferenceError: Can't find variable: debugOut initMarkerFromInput (game.js:509) (anonymous function) (bec5fba4a7fb44c6:331) c (jquery-1.10.2.min.js:4:26042) fireWith (jquery-1.10.2.min.js:4:26842) ready (jquery-1.10.2.min.js:4:3317) q (jquery-1.10.2.min.js:4:723)


Falls du ein Gerät mit MacOS hast, kannst du wie folgt simulieren:
1) Aktuellstes XCode herunterladen (AppStore)
2) Simulator starten und unter Hardware in iOS 9.3.5 ein iPad wählen, weiter zu 3)
2a) Falls iOS 9.3.5 nicht auftaucht. XCode schliessen und Legacy XCode 10.2.1 für "alte iOS" Versionen herunterladen: https://developer.apple.com/download/mor..
2b) Entpacken und die entpackte XCode.app starten
2c) Unter XCode / Preferences / Components die gewünschten iOS Simulatoren herunterladen (habe mal 8.x, 9.x und 10.x gewählt)
2d) Entpackte XCode.app schliessen und wieder "normale" XCode.app starten, weiter bei 2)

3) Safari auf dem Desktop-Computer starten und ggf. Developer-Menu einschalten
4) Unter Develop das simulierte iPad wählen und debuggen.

Im Simulationsfenster der iPad-Version surfen und im Debug-Fenster der lokalen Safari-Version debuggen - eigentlich ganz elegant (wenn auch in der Vorbereitung etwas mühsam *g*)!

siramon - 10.01.20    

Polyfill für let (ecmascript6) ist nicht trivial, aber das hier könnte ein Ansatz sein: https://github.com/getify/You-Dont-Know-..

shaack - 10.01.20    

@siramon Super cool! Danke! Ja ich hab nen Mac und werde das gleich mal ausprobieren.

shaack - 10.01.20    

So, bitte jetzt noch mal auf den alten iPads testen, es sollte wieder funktionieren. Und bitte vorher den Borwsercache löschen!

algorithmus888 - 10.01.20    

Juhu, ich kann wieder Züge eingeben.
Danke für Deine Bemühungen, shaack.
Du bist echt der Chef!

shaack - 10.01.20    

Danke, und danke auch an @siramon, der den Fehler in "portal.js" gefunden hat!

Karl_Lang - 11.01.20    

Mobilversion funktioniert auf meinem iPad 3/Safari/WLAN.
Leider nicht sehr komfortabel.

Karl_Lang - 11.01.20    

Bestätigung für mein Gerät. Alles funzt wieder. Danke!

siramon - 13.01.20    

Cool klappt alles wieder :-)

@shaack, gerne. War auch für mich lehrreich!