chessmail

ausgrauen inkonsistent

toby84 - 29. Nov '23
seit vorgestern scheint das cookie für das ausgrauen nicht mehr richtig zu funktionieren. es kommt immer wieder vor, dass große teile des forums als ungelesen dargestellt werden, obwohl es kurze zeit vorher noch funktioniert hat. wenn ich erneut den gelesen-button drücke, ist wieder alles in ordnung. an und für sich ist das auch nicht schlimm. es fällt mir nur auf, weil es seit vorgestern so häufig vorkommt. es war jetzt mindestens 5 mal. früher kam das nach subjektiver schätzung höchstens alle paar wochen mal vor.
shaack - 29. Nov '23
Das Verhalten ist vor allem Browserabhängig. Wenn man z.B. den Verlauf löscht wird auch diese Information gelöscht.
toby84 - 29. Nov '23
das klingt plausibel, nur lösche ich meinen verlauf eigentlich nicht. wenn ich wüsste, welches cookie für die anzeige verwendet wird, könnte ich prüfen, ob es noch existiert, wenn die anzeige mal wieder fehlerhaft ist.
schach2018 - 29. Nov '23 Edited
Ich habe den "Verlauf" seit Wochen nicht mehr gelöscht. Das Ausgrauen bestimmter Foren muss ich auch über den gelesen-Button manchmal an einem Tag wiederholen, bis es abgespeichert ist.

Nachtrag:
Habe den Cache geleert. Es hat leider nicht geholfen.

Den aktuellen Beitrag "OpaJuergen" von SF Okute habe ich gerade gelesen. Trotzdem zeigt mir die Forenübersicht dies nicht an. Nur durch den gelesen-Button wird er ausgegraut.
shaack - 29. Nov '23 Edited
@toby84 Das ist kein Cookie, das macht der Browser selbst mit seinem Browser-Verlauf. Wenn es nicht geht, dann "will" das der Browser so. Siehe: https://developer.mozilla.org/en-US/docs/Web/CSS/:visited?reti..

"For privacy reasons, the styles that can be modified using this selector are very limited"

Das handhabt jeder Browser anders.
toby84 - 29. Nov '23
ok das ist schade. danke für die info.
schach2018 - 29. Nov '23 Edited
Ich habe den Chrome-Browser nie geändert/ gewechselt. Es hat früher bzw. Monate vorher auch funktioniert...🤔Scheinbar sind wir die einzigen mit diesem Problem...

bearbeitet: ergänzt
toby84 - 29. Nov '23
der chrome-browser kann sich schon aktualisieren, wenn du ihn einfach nur schließt und öffnest. also auch jedes mal, wenn du das gerät neu startest. hast du das im blick bei deiner behauptung?
timi - 29. Nov '23 Edited
@schach2018: Nein, das seid ihr nicht. Mir passiert das auch auf dem iMac mit Safari in letzter Zeit öfters, dass plötzlich viele, aber nicht alle Beiträge als ungelesen erscheinen. Erst das Drücken des "Gelesen"-Buttons bringt dann wieder die gewohnte Darstellung.


Bearbeitung: Ergänzt
toby84 - 29. Nov '23 Edited
wenn man das ausgrauen von der chronik auf cookies umstellen würde, wäre es verlässlicher und nicht von aktuellen browser-sicherheitsbestimmungen abhängig. chessmail nutzt sowieso cookies, also könnte man das recht schmerzfrei umbauen, oder? wenn relativ viele chessmailer das problem haben, wäre das doch eine überlegung wert.
underdunk - 09. Dez '23
@shaack, da ist mit Sicherheit was faul.

Eben hatte ich in der Übersicht zahllose ungelesene Beiträge. Ich habe dann absichtlich nicht den "Gelesen" Button benutzt, sondern bin auf die Suche nach diesem Thread hier ins chessmail Forum gegangen. Als ich zurück zur Übersicht kam, war wieder alles grau. (Ich hatte heute morgen auf "Gelesen" geklickt.)
aguirre - 09. Dez '23
Hallo,
ich nutze Firefox, Version aktuell und auch bei mir erscheinen immer wieder viele Beiträge als ungelesen.
Stört mich nicht, drücke halt nochmal den "gelsen Button", aber vielleicht hilft die Info bei der Fehlersuche.
Schönen zweiten Advent allen.
schach2018 - 09. Dez '23 Edited
Trotz Nutzung des Gelesen-Buttons erscheinen die Beiträge nach einer gewissen Zeit wieder als nicht gelesen.
Oli1970 - 09. Dez '23
Gestern hatte ich zweimal, dass ca. die Hälfte der Forenübersicht als ungelesen dargestellt wurde, und zwar nachdem ich die Webseite durch „Herunterziehen“ aktualisiert hatte (iPhone, Safari aktuell). Erneutes Aktualisieren brachte dann die erwartete „Gelesen“-Ansicht.

Möglicherweise eine Kombination aus Browserverhalten und Gelesen-Button? Ich nutze den Button relativ häufig, andererseits lese ich die meisten Beiträge, so dass ich nicht identifizieren kann, welche Beiträge auf welche Weise hätten ausgegraut sein müssten.

Reproduzierbar ist das Verhalten nicht, möglicherweise daher vom sonstigen, zwischenzeitlichen Surfverhalten abhängig.
toby84 - 11. Dez '23
ist gerade wieder passiert. aktualisieren der seite hat bei mir auch geholfen. das erneute ausgrauen war tatsächlich nicht nötig.
MarkD - 11. Dez '23
hier gerade auch, genau so...
Oli1970 - 13. Dez '23
Ist eben wieder passiert. Mir fiel auf, dass unsere clubinternen Beiträge in der (inkonsistenten) Ansicht nicht vorhanden waren. Die als ungelesenen gekennzeichneten Beiträge waren mit hoher Wahrscheinlichkeit die, die ich nicht direkt angesehen, sondern via Button ausgegraut hatte. Ohne absolute Sicherheit, aber es scheint, dass laut Browserverlauf besuchte Links doch zuverlässig dargestellt sind.
Nach Aktualisierung war die Forenübersicht wie erwartet (alles gelesen, clubinterne Nachrichten angezeigt). Wird in Einzelfällen die Forenübersicht aufgerufen oder neu geladen ohne vorher den angemeldeten User zu identifizieren? Hat chessmail einen Schluckauf? 😅
toby84 - 13. Dez '23
das wäre dann ein häufiger. heute war es wieder so. das kommt zur zeit fast täglich vor.